1. REGISTRATION REQUIREMENTS:

    Register with your xenforo.com Username then start a conversation at xenforo.com w/Bob and provide the following:
    1. Your XenForo License Validation Token
    2. The Domain Name associated with the License
    NOTE: Your account will be validated once ALL requirements are verified/met. Thank you for your patience.

Login Button is missing from Showcase page

Discussion in 'Showcase Support' started by clove, Jun 29, 2015.

  1. clove

    clove Member Showcase

    I notice that the login button is not showing on Showcase (Reviews) page but the other pages have. Please help..

    UPDATE: I just realized that the login buttons are from my customize style. How can I put those button into Showcase Page as well?
     
    Last edited: Jun 29, 2015
  2. Bob

    Bob Developer Staff Member

    Doesn't make sense. Showcase uses the core xenforo sidebar (which includes the visitor block by default (which includes the login part)). The login part of the visitor block only displays when the viewing user is NOT logged in. If you inbox me some login credential (admin account with access to styles), I can check it out for you.
     
  3. clove

    clove Member Showcase

    Hi Bob, I've decided to just leave it like that. Anyway, I'm having a difficulty in finding out where to change the color for this(refer to the image below). If you notice, below the "Discuss This Item" has some white text. Where can I change the color of that text so it will be visible? Thank you!

    upload_2015-7-13_23-53-16.png
     
  4. Bob

    Bob Developer Staff Member

    Im going to need a LINK to your site so I can see that block and view the HTML and CSS classes. If you don't want to post the URL public, send me an inbox with it.
     
  5. clove

    clove Member Showcase

    Hi Bob here's the link to my site: http://www.pefcommunity.com
     
  6. Bob

    Bob Developer Staff Member

    Your custom style is changing core xf css for the call to action button (adding additional elements) which are effecting the use of the <small> tag.

    Selection_451.png

    You can see here that when I disable the addition non core XF CSS elements, it works as it should.

    Selection_452.png

    You'll need to do something like this (add this to Extra.css for the custom style.

    HTML:
    .nflj_showcase_item .sidebar a.callToAction span {
        height: inherit;
        line-height: normal;
    }
     
  7. clove

    clove Member Showcase

    Thank you @Bob it worked! Anyway, where can I set the prefix? It always ask for a prefix but I already removed the prefixes. I cannot create new item. :(
     
  8. Bob

    Bob Developer Staff Member

    Showcase has its OWN Prefix System that is separate from Thread Prefixes. What MIGHT be happening is that you have the "Require" option set on one or more of your Showcase Category's via the Prefix Tab settings...

    Edit each of your category's and check the Prefix Options Tab settings and make sure you don't have the option marked with the RED ARROW checked.

    NOTE: the TITLE of that is wrong... it should say "Default Item Prefix" (this is fixed in the next version).

    Selection_464.png
     
    clove likes this.
  9. clove

    clove Member Showcase

    Thanks a lot Bob! I've searched everything but the category settings. :D
     
    Bob likes this.
  10. clove

    clove Member Showcase

    Hi @Bob,

    The Reviews tab still has the problem.

    upload_2015-7-20_16-34-57.png
     
  11. Bob

    Bob Developer Staff Member

    This should cover everything

    HTML:
    .nflj_showcase_item .sidebar a.callToAction span,
    .nflj_showcase_reviews .sidebar a.callToAction span,
    .nflj_showcase_item_field .sidebar a.callToAction span
    {
        height: inherit;
        line-height: normal;
    }
     
    clove likes this.
  12. clove

    clove Member Showcase

    Thank you so much Bob!
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.