1. REGISTRATION REQUIREMENTS:

    Register with your xenforo.com Username then start a conversation at xenforo.com w/Bob and provide the following:
    1. Your XenForo License Validation Token
    2. The Domain Name associated with the License
    NOTE: Your account will be validated once ALL requirements are verified/met. Thank you for your patience.

Prefix Issue

Discussion in 'Showcase Support' started by viper357, May 1, 2016.

  1. viper357

    viper357 New Member Showcase

    Hi Bob

    I'm not sure if it's a bug or if I've missed something?

    When I initially set up Showcase I used prefixes and added them to most of the articles, I later decided against them and removed all of the prefixes a while ago. Today I was editing an old article that used to have a Prefix but when trying to save it I get a popup saying "please select a prefix", even though there are none defined. I have been through all of the options but can't see a way to rectify this?

    Thanks.
     
  2. Bob

    Bob Developer Staff Member

    When the "Please select a prefix" error pops up, that means you have the setting "Require users to select a prefix" enabled. Even if there are no prefixes, if you have that option set, its going to throw an error. You need to edit your Categories, look at the Prefix Options Tab options and disable "Require users to select a prefix"

    Selection_038.png
     
  3. viper357

    viper357 New Member Showcase

    I checked that, as well as the one in the Node Tree, both are unchecked yet it still gives that error.

    x1.jpg

    x2.jpg
     
  4. Bob

    Bob Developer Staff Member

    I don't know what to tell you. Its very simple code (see code below). If that option is CHECKED for that category, then it throws that error on Pre Save checks for any items in that category. That is the ONLY PLACE in which that specific ERROR PHRASE comes into play in Showcase.

    PHP:
            if ($category['require_prefix'] && !$writer->get('prefix_id'))
            {
                
    $writer->error(new XenForo_Phrase('please_select_a_prefix'), 'prefix_id');
            }
    If you want me to troubleshoot your issue further, I am going to need access to your site and DB. Send me an inbox with login credentials.

    Try this... edit the category that the ITEM is owned by. Check that option, SAVE. Edit it again, then UNCHECK it and SAVE. Then go back to the ITEM, make sure you fully render the item again, then EDIT the ITEM (this ensures that the category data is fetched FRESH (not cached). Then try and save it make sure it shows the term (No prefix).
    Selection_039.png
     
  5. viper357

    viper357 New Member Showcase

    That seems to have fixed it. Thanks. :)
     
    Bob likes this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.