1. REGISTRATION REQUIREMENTS:

    Register with your xenforo.com Username then start a conversation at xenforo.com w/Bob and provide the following:
    1. Your XenForo License Validation Token
    2. The Domain Name associated with the License
    NOTE: Your account will be validated once ALL requirements are verified/met. Thank you for your patience.

Hide in navigation bar of a custom style

Discussion in 'Showcase Support' started by clove, Aug 11, 2015.

  1. clove

    clove Member Showcase

    Hi bob, I managed to hide showcase in navigation bar using the code in extra.css but it's still showing in mobile view. I'm using a custom style by audentio.

    How can I hide it in mobile view?
     
  2. Bob

    Bob Developer Staff Member

    You'll need to ask Audentio about that. They have and are familiar with Showcase, so they should be able to help you out in a jiffy :)
     
    clove likes this.
  3. clove

    clove Member Showcase

    Thanks Bob. Here's the reply of one of their staffs.

    "Are you referring to hiding it from the offcanvas menu? I don't have that addon installed to give you the exact class, but if you look at the specific navigation item in the offcanvas menu and it has a unique class you could do something in your extra.css template to hide it similar to this:

    .uix_offCanvasNavigation li.(unique class) {display: none;}

    That said, this type of customization is beyond the scope of our standard support and I'm only sharing it to help you get started.

    Hope that helps,"

    But I don't know how to look for that class..:(
     
  4. Bob

    Bob Developer Staff Member

    unique class = showcase (at least it should). I can inspect your site with firebug and let you know if that is correct (post your URL or send it to me in private).

    .uix_offCanvasNavigation li.showcase {display: none;}
     
    clove likes this.
  5. clove

    clove Member Showcase

    Thank you so much Bob! It is working now. :)
     
    Bob likes this.
  6. clove

    clove Member Showcase

    @Bob I'd like to ask for help again because the support at Audentio is really terrible. Since the upgrade of their theme, this code doesn't work anymore.

    Code:
    .uix_offCanvasNavigation li.showcase {display: none;}
    
     
  7. Bob

    Bob Developer Staff Member

    I don't have any 3rd party styles, so the ONLY way I can help is if users give me access to their SITE via a URL at the minimum so that I can inspect the HTML/CSS to see what classes are being used. If you don't want to post your URL publicly, then start a conversation with me.
     
  8. clove

    clove Member Showcase

    Here's my site: http://www.pefcommunity.com

    Thank you Bob!

    EDIT: Please use the Pef Community UI.X style.
     
  9. Bob

    Bob Developer Staff Member

    This works for me

    HTML:
    .navTab.showcase {
    display: none;
    }
    Add important to it in case a priority is overriding it.
    HTML:
    .navTab.showcase {
    display: none !important;
    }
     
  10. clove

    clove Member Showcase

    I've tried it but it is still there..

    upload_2015-9-7_21-34-24.png
     
  11. Bob

    Bob Developer Staff Member

    I THINK you are either NOT adding it correctly, not using !important; or adding it to the wrong STYLE

    Selection_717.png
     
  12. Bob

    Bob Developer Staff Member

    Try THIS....

    HTML:
    .uix_sidePane ul#uix_offCanvasVisitorMenu li, .uix_sidePane .navTab.showcase {display:none !important;}
     
    clove likes this.
  13. clove

    clove Member Showcase

    This worked! Thank you so much for your help Bob! ;)
     
  14. Bob

    Bob Developer Staff Member

    BOTH of them work. When you said the that other one didn't work, it wasn't even showing up. Not BOTH of them are showing up. Here you can see that I disabled the last one I posted to show you that the first one works as well.

    Selection_718.png
     
  15. Paul McGregory

    Paul McGregory New Member Showcase

    This works with the desktop version, but there is no class showcase in the mobile version. How can I hide the NavigationTab showcase?
     
    Last edited: Jul 3, 2018
  16. Bob

    Bob Developer Staff Member

    Depends on the 3rd party style that you are using. Some of the popular styles designers (ThemeHouse, PixelExit etc), have their own special classes that need to be used.

    Everything in this post about the sidenav is specific to UI.x (at the time of the post, so it may have changed between then and now). If you are using a PixelExit style, the sidenav CSS isn't going to work as they have their own unique CSS classes.

    I'll need a link to your site (and be able to view Showcase so that I can see the navigation tab).
     
  17. Bob

    Bob Developer Staff Member

    The TAB that is currently visible is not the actual Showcase Tab, its a custom tab being added by an addon called "Sirupo Custom Tabs". The REAL Showcase Tab IS being hidden.

    As you can see in the code below, there are TWO Showcase Tabs being added to the Navigation. One of them (Mine), includes the class "showcase". It is currently HIDDEN (as the code is MUTED which means its display: none). The other Showcase Tab is being added by Sirupo Custom Tabs. This tab doesn't have the showcase class, it has the class "siropuCustomTab" and "custom-tab-7".

    Selection_972.png

    When we view your site, we only see the Tab that the sirupo custom tabs addon is adding to the navigation as the Showcase tab being added by Showcase is being HIDDEN by display:none.

    Selection_975.png

    When I remove the CSS that you applied to the REAL Showcase Tab, you can see the Showcase Tab being displayed to the right of the Showcase tab being added by the Sirupo Custom Tab addon.

    Selection_974.png
     
  18. Paul McGregory

    Paul McGregory New Member Showcase

    Yes i know.

    i want to remove the original showcase Link (already deactivated with display:none) and I have created a new custom Tab with my own Subnavi.

    The desktop version works fine, but the mobile (responsive) version doesn work.

    The question is: how do I deactivate the original showcase Navi-Point?
     
  19. Bob

    Bob Developer Staff Member

    There is no such thing as a "desk top version" and a "mobile version". XenForo uses a Responsive Layout (its always responsive). There are 4 Responsive Break Points (Default, Wide, Medium and Narrow). The actual Showcase Tab (the one added by the Showcase Addon) is being HIDDEN in all 4 responsive break points on your site.

    Here is your site with the only style that guests can see and the 'gallery' Tab that is displayed in this screenshot is a sirupo Custom Tabs addon (NOT Showcase). The Showcase Tab is being HIDDEN BY CSS in ALL responsive break points (this screen shot is shown in NARROW responsive break point and the Showcase Tab is not being displayed.)

    Selection_977.png

    If you REMOVE the CSS that you are using to HIDE the Showcase Tab, the actual Showcase Tab will display (and you will have 2 TABS (one named 'gallery' (which is being added by Sirupo Custom Tabs) and one called "Galleries" which is the actual Showcase Tab.

    Selection_979.png


    Here is your site at NARROW responsive break point (the lowest) and only the 'gallery' tab is being displayed (that Tab is NOT Showcase, its a Custom Tab being added by Sirupo Custom Tabs). The Showcase Tab (being added by Showcase) is HIDDEN (other wise it would display as either a TAB or in the dropdown as a link).

    Selection_981.png

    If I REMOVE the CSS that you added to HIDE the Showcase Tab, then the actual Showcase Tab displays.

    Selection_980.png

    So what you are doing IS working for the actual Showcase Tab in all responsive break points (as it should as that is default core xenforo behavior).

    You keep saying that the Showcase Tab is being displayed and I've had 5 different people (to inlcude a Core XenForo Developer) look at your site and all of them see the same thing as I do and that is the Showcase Tab is HIDDEN in all 4 responsive break points.

    Can you post a Screen Shot of what YOU are seeing that is different than what screen shots I am posting? Maybe you are viewing a different STYLE that guests can see.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.