1. REGISTRATION REQUIREMENTS:

    Register with your xenforo.com Username then start a conversation at xenforo.com w/Bob and provide the following:
    1. Your XenForo License Validation Token
    2. The Domain Name associated with the License
    NOTE: Your account will be validated once ALL requirements are verified/met. Thank you for your patience.

Category Maps not showing?

Discussion in 'Showcase Support' started by Gina, Apr 29, 2020.

  1. Gina

    Gina New Member Showcase

    Hello, we installed the latest version of Showcase for XF2 and can't get the category map to display.

    We have the options enabled for Enable category map and Enable full page category map, along with the the required API keys:
    • Google Maps Embed API Key
    • Google Maps JavaScript API Key
    • Google Maps Geocoding API Key
    The google map displays on the actual item listing for that specific item, but not on the category page where we want to display all of the items in the category at once on the map.

    Also - clicking "View Full Map" button doesn't display it either, it just says "No items have been added yet."

    Any ideas as to why it may not be displaying? Is this perhaps controlled by a widget that we may have disabled?

    Thank you!
     
    Last edited: Apr 29, 2020
  2. Bob

    Bob Developer Staff Member

    My guess is that Google is rejecting the Geocoding API key from your server. Every single time someone has an issue with this, its due to the Geocoding API being blocked by google (as they are detecting that your server should not have access to the API because of restrictions that you put on the API key in the google counsel).

    That uses the Google Maps EMBED API and has no connection with Category maps which use the JavaScript API and Geocoding API.

    You didn't mention running the REBUILD LOCATION DATA. Did you perform that task? If not, run that Cache Rebuild as it might be that you just have not populated the Location Data cache yet.
     
  3. Eric

    Eric New Member AMS Premium SC Premium

    I'm having this same issue. I checked my API and it is set to allow the entire domain. My XF1 site (same domain & API keys) this works fine.

    Here are the restrictions on my API key
    upload_2020-5-28_14-21-42.png

    I also ran the Rebuild Locations cache as you mentioned above. The only place I get a map displayed is when I click on the location link in the sidebar on the item page.
     
  4. Bob

    Bob Developer Staff Member

    You didn't mention anything about checking the CATEGORY settings for Category Maps. Can you verify that those are set? They are NEW for the XF2 version of Showcase, so if you've upgraded from XF1 to XF2, you'd need to edit the categories and set all the new Category Maps options.
     
  5. Eric

    Eric New Member AMS Premium SC Premium

    Sorry, yes I have it set.

    upload_2020-5-28_15-14-24.png

    I can give you Admin access if you want. No rush on it, the site isn't live as I am still moving things over from XF1 & VB4 (I didn't perform an upgrade, it is a fresh install)
     
  6. Bob

    Bob Developer Staff Member

    Ya, I can take a look this weekend if you inbox me login credentials :)
     
    Eric likes this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.