• REGISTRATION REQUIREMENTS:

    Your username here MUST MATCH your XenForo username (connected to your XF license).

    Once you have registered here, then you need to start a conversation at xenforo.com w/Bob and provide the following:
    1. Your XenForo License Validation Token
    2. The Domain Name associated with the License
    NOTE: Your account will be validated once ALL requirements are verified/met. Thank you for your patience.

Fixed Issue with some CSS in the core_xa_cas.less template

Saul

New Member
CAS Premium
CAS Version
2.2.36
XenForo Version
2.2.13
PHP Version
8.3.2
Database & Version
MySQL 5.7.42
Are there any errors being throw?
Yes
Hi Bob!

Small problem :)
After I installed CAS on the forum, I can't properly edit any of the templates on the forum. Even those that have nothing to do with CAS.
For example, I just modified the account_signature template by simply adding text.

As soon as I saved the template changes, all the forum pages turned into a jumble of letters and words without CSS. And there was an error on a yellow background:

1720459666691.png

I did a search and found the line
Code:
`background: mix(@xf-textColorMuted, @xf-avatarBg, 25%) !important;`
in the file core_xa_cas.less


I commented out this line, and the problem immediately disappeared.

EDIT: Removed errors that has nothing to do with CAS! CAS does not have anything to do with SVG (not a single line of code in CAS dealing with SVGs).
 

Attachments

  • 1720459857661.png
    1720459857661.png
    83.1 KB · Views: 4
Last edited by a moderator:
Its CSS copied from XFRM (which has recently been updated.
I did a search and found the line
Code:
`background: mix(@xf-textColorMuted, @xf-avatarBg, 25%) !important;`
in the file core_xa_cas.less
Try replacing it with this (this is the updated CSS in XFRM for the same use case).

background: mix(xf-default(@xf-textColorMuted, black), xf-default(@xf-avatarBg, white), 25%) !important;
 
Try replacing it with this (this is the updated CSS in XFRM for the same use case).

background: mix(xf-default(@xf-textColorMuted, black), xf-default(@xf-avatarBg, white), 25%) !important;
I just confirmed this fix in XFRM, AMS, CAS, EMS, IMS, LD, RMS, Showcase and UBS (both for the XF 2.2 and XF 2.3 versions).

You will have to apply this manually for the XF 2.2 version of CAS. I just updated CAS 2.3.0, so it will be applied automatically when upgrading to CAS 2.3.0.

Extremely weird that its been this way for several YEARS and not a single license holder found it until TODAY!
 
Back
Top