Your username here MUST MATCH your XenForo username (connected to your XF license).

    Once you have registered here, then you need to start a conversation at xenforo.com w/Bob and provide the following:
    1. Your XenForo License Validation Token
    2. The Domain Name associated with the License
    NOTE: Your account will be validated once ALL requirements are verified/met. Thank you for your patience.

Getting internal server error when editing existing showcase items/threads


AMS Premium
IMS Premium
RMS Premium
SC Premium

I'm trying to sort this out - is there some kind of size limitation for very long articles or such in Showcase? I expanded the tab1 input settings to 100000 (as well as XF's message settings) and there is no problem creating new items but whenever I try to edit said item, it throws an internal server error (data not available in XF error logs).

If I delete the body of text, the error goes away so that's why I'm guessing there is some kind of text limitation in editing mode that doesn't trigger upon creation of the original item.

What else can I tweak/check to further sort this out?

is there some kind of size limitation for very long articles or such in Showcase?
Nothing that I've implemented. Even tho showcase has a MAX setting, it can't exceed the Core XF setting for the max message size (nor can it exceed PHP limitations). Usually when there is an internal server error (that is so generic), that means its some kind of PHP.ini limitation in place.

I'll have to do some internal testing this weekend to see if I can reproduce it (in case there is some kind of weird bug).

Would it be possible to access your system this weekend?
I decided on a whim to try it on a regular post and I got the same error, so please hold off on this... I'm going to dive deeper into this now that I've triggered it outside of Showcase... Will keep you posted.
Okay, I think I isolated it -- I was copying very long posts from an old forum I migrated from by going into the post editor of old post and copying it from there into the database. This time I straight copied it from the webpage rather than the editor and it worked so I'm guessing there's some hidden characters copied in the editor that breaks XF.

It is odd though it doesn't trigger upon creation of thread/item. Just upon editing.

Sorry about that!
  • Like
Reactions: Bob