1. REGISTRATION REQUIREMENTS:

    Register with your xenforo.com Username then start a conversation at xenforo.com w/Bob and provide the following:
    1. Your XenForo License Validation Token
    2. The Domain Name associated with the License
    NOTE: Your account will be validated once ALL requirements are verified/met. Thank you for your patience.

Server Error: open_basedir

Discussion in 'Stock Trader Support' started by dehness, Sep 28, 2016.

  1. dehness

    dehness New Member Stock Trader Sportsbook

    Sorry I should've posted this here:

    I ran a package update on the server a couple of days ago, and ever since we've been getting this error for the stock trader add-on (or at least I've only noticed it since the update):
    As far as I understand, the open_basedir directive is a security protocol designed to prevent specific PHP environments from accessing deeper into the filesystem than is required to run each virtual environment.

    This directive has always been defined on the server and nothing has changed as far as I can tell (the php.ini and vhost .conf files appear the same), so I'm not sure why the add-on suddenly doesn't function. I can only guess something has been overwritten during the update?

    So far this has only affected the Stock Trader add-on so Xenforo.com have been unwilling to help me.

    We're running nginx and ubuntu.
     
  2. Bob

    Bob Developer Staff Member

    I had this same issue when converting from apache to nginx. My server admin @MattW fixed it for me. Im sure Matt would help you if you sent him an inbox (tell him I sent you since he fixed the same issue for me).

    Stock Trader is the only addon of mine that uses CURL.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.