1. REGISTRATION REQUIREMENTS:

    Register with your xenforo.com Username then start a conversation at xenforo.com w/Bob and provide the following:
    1. Your XenForo License Validation Token
    2. The Domain Name associated with the License
    NOTE: Your account will be validated once ALL requirements are verified/met. Thank you for your patience.

Fixed [E_NOTICE] Undefined index: category_id

Discussion in 'Showcase Resolved Bug Reports' started by Sadiq6210, Jan 5, 2019.

  1. Sadiq6210

    Sadiq6210 Member Showcase

    After I upgraded from SC2 to SC3.0.1, I am getting this error in admincp server error logs:

    Code:
    ErrorException: [E_NOTICE] Undefined index: category_id src/addons/XenAddons/Showcase/Report/Item.php:15
    Generated by: USER 5 Jan 2019 at 1:07 PM
    
    Stack trace
    #0 src/addons/XenAddons/Showcase/Report/Item.php(15): XF::handlePhpError(8, '[E_NOTICE] Unde...', '/home/username/...', 15, Array)
    #1 src/XF/Report/AbstractHandler.php(19): XenAddons\Showcase\Report\Item->canViewContent(Object(XF\Entity\Report))
    #2 src/XF/Entity/Report.php(45): XF\Report\AbstractHandler->canView(Object(XF\Entity\Report))
    #3 src/XF/Mvc/Entity/AbstractCollection.php(298): XF\Entity\Report->canView()
    #4 [internal function]: XF\Mvc\Entity\AbstractCollection->XF\Mvc\Entity\{closure}(Object(XF\Entity\Report))
    #5 src/XF/Mvc/Entity/AbstractCollection.php(167): array_filter(Array, Object(Closure))
    #6 src/XF/Mvc/Entity/AbstractCollection.php(299): XF\Mvc\Entity\AbstractCollection->filter(Object(Closure))
    #7 src/XF/Repository/Report.php(103): XF\Mvc\Entity\AbstractCollection->filterViewable()
    #8 src/XF/Pub/App.php(226): XF\Repository\Report->filterViewableReports(Object(XF\Mvc\Entity\ArrayCollection))
    #9 src/XF/Pub/App.php(123): XF\Pub\App->updateModeratorCaches()
    #10 src/XF/App.php(1930): XF\Pub\App->start(true)
    #11 src/XF.php(333): XF\App->run()
    #12 index.php(13): XF::runApp('XF\\Pub\\App')
    #13 {main}
    
    Request state
    array(4) {
      ["url"] => string(7) "/forum/"
      ["referrer"] => bool(false)
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(0) {
      }
    }
     
  2. Bob

    Bob Developer Staff Member

    Similar to an issue both XFRM and XFMG had (legacy reports issue). I'll get it sorted :) You can just delete those for now.

    Edit: I've applied the same fix as XFMG.

    Note: This only applies to Showcase Item reports (not other content_type reports).
     
    Last edited: Jan 11, 2019
    Sadiq6210 likes this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.